Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3836 closed defect (fixed)

potlatch2.2 locks up, unable to save edited data

Reported by: Peter Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

I'm regularly getting potlatch2 (reproduced on V2.2 Build 2.2-1-gdec4a94) locked up and unresponsive. Sometimes I notice that after clicking or deselecting any node or way it does not change their description bar at the left side (and then try immediately press Save, which successfully saves my (albeit unfinished, but at least some) work), but sometimes it is already late and after clicking Save, the whole potlatch area just gets faded out... and the edits were gone.

It happens at least on my each second edit (1-2 hours of work). And as I do not like to save "unfinished partial work"... it happens pretty often. On two different machines with Chrome browser.

After reading kerosin's similar report in Diary http://www.openstreetmap.org/user/kerosin/diary/14153, I've tried to reproduce it, and found one possible way to get Potlatch into such state:

Create some way (triangle or rectangle, does not matter, single point is sufficient), switch to advanced tag view and "accidentally" create two fresh "(new tag) (new value) (x)" lines instead of just one. Ooops! Lets delete one... but just the "(new value)" part in the Value column gets deleted. At this moment the object's properties bar is (b)locked - clicking any point or way does not change it. If you now say "Panic!" and press Save, potlatch is gone, fades out and... Germans say "Das war's". Farewell my data...


During testing I've now found out an "emergency break": if I notice some object has got multiple unfilled "(new tag) (new value) (x)" lines, I may completely delete this object and potlatch remains functional. That's fine with my fresh new object. But if it is someone other's nontrivial, complex object I've just accidentally modified (while wishing to add just one new tag)...


How to "accidentally" create multiple "(new tag) (new value) (x)" lines? I wish to make a double-click to add a new tag (but "accidentally" make a triple-click or one more double-click into a fresh "(new tag) (new value) (x)" line), or I press the Add button twice, and I immediately have (at least) two such lines. I believe potlatch might recognize that the line is not edited yet and might refuse to create another one.

Attachments (1)

OSM Potlatch2 locked on Save.PNG (126.4 KB) - added by Peter 8 years ago.
OSM potlatch2 dimmed and locked on save

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Peter

OSM potlatch2 dimmed and locked on save

comment:1 Changed 8 years ago by Richard

Fix committed in https://github.com/systemed/potlatch2/commit/4011001a1b02966da3d440682a6829c0f1b3c984 .

Also, save your work _regularly_. At least every ten minutes. If you don't like to save "unfinished partial work" you shouldn't really be using a webapp, at least not one that doesn't allow you to save locally. Potlatch 2 will now remind you if you go 20 minutes without saving.

comment:2 Changed 8 years ago by Richard

Resolution: fixed
Status: newclosed

comment:3 Changed 8 years ago by Peter

Thanks for nearly instant fix of the bug - I'm at least not able to reproduce it this way again.

(I'll try to break my ideas into smaller steps :-)

Note: See TracTickets for help on using tickets.