Opened 8 years ago

Closed 8 years ago

#3850 closed defect (fixed)

Vector.xml support broken for multiple gpx files in P2.2

Reported by: Nop Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

I use a vector.xml file to add multiple gpx tracks to Potlatch. E.g. in this instance I added 4 gpx tracks.

In potlatch, there are 5 entries, 4 gpx files and one main. But the gpx files all have the same name (the name of the last entry in the vector.xml) and only the last gpx file is shown. Changing the visible state works only for the Main layer, for the gpx files nothing happens.

The same vector.xml worked fine in the old P2 before switching over to P2.2. It was possible to show multiple gpx tracks at the same time. There was no change in the config except migration from P2 to P2.2.

I have attached the vector.xml.

Attachments (1)

vectors.xml (953 bytes) - added by Nop 8 years ago.
Vectors XML file with 4 gpx tracks, works in P2, fails in P2.2

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Nop

Attachment: vectors.xml added

Vectors XML file with 4 gpx tracks, works in P2, fails in P2.2

comment:1 Changed 8 years ago by Richard

Resolution: fixed
Status: newclosed

Fixed in https://github.com/systemed/potlatch2/commit/725a5a1cdb911463a2253774a7989066252024c4. I have no idea how come it worked originally. ;)

Note: See TracTickets for help on using tickets.