Opened 8 years ago

Closed 8 years ago

#3858 closed defect (fixed)

Tag editor panel blanks out (goes white)

Reported by: randomjunk Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

Tag editor panel blanks out (goes white), preventing you from making edits. Some functionality continues to work, but everything goes a little mental.

Steps to reproduce:

  • select a recognised node/way
  • in the tag editor select the "Naming" tab (or any tab but the first one)
  • click on the map to deselect
  • click on the map to start drawing a new way

==> panel blanks out and you have to reload to recover

Change History (3)

comment:1 Changed 8 years ago by Andy Allan

It's been triggered from a closure or similar, since the traceback doesn't indicate which bit of p2 is causing it.

RangeError: Error #2006: The supplied index is out of bounds.
	at flash.display::DisplayObjectContainer/getChildAt()
	at mx.core::Container/getChildAt()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\core\Container.as:2367]
	at mx.controls::ToggleButtonBar/hiliteSelectedNavItem()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\controls\ToggleButtonBar.as:441]
	at mx.controls::ToggleButtonBar/commitProperties()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\controls\ToggleButtonBar.as:333]
	at mx.core::UIComponent/validateProperties()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\core\UIComponent.as:5818]
	at mx.managers::LayoutManager/validateProperties()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\managers\LayoutManager.as:539]
	at mx.managers::LayoutManager/doPhasedInstantiation()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\managers\LayoutManager.as:689]
	at Function/http://adobe.com/AS3/2006/builtin::apply()
	at mx.core::UIComponent/callLaterDispatcher2()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\core\UIComponent.as:8744]
	at mx.core::UIComponent/callLaterDispatcher()[C:\autobuild\3.5.0\frameworks\projects\framework\src\mx\core\UIComponent.as:8684]

I suspect https://github.com/systemed/potlatch2/commit/8f4239262c5e7ab762c194e4bf34997d9c722543 if anyone wants to git-bisect it.

comment:2 in reply to:  description Changed 8 years ago by Peter

Replying to randomjunk:

Tag editor panel blanks out (goes white), preventing you from making edits. Some functionality continues to work, but everything goes a little mental.

Sometimes when afterwards selecting some way, the way's tag selector pops up, but seems to be fixed to the least recently used tags type (e.g. Paths). After selecting some point or deselecting all the panel goes blank again.

comment:3 Changed 8 years ago by Richard

Resolution: fixed
Status: newclosed

Fixed in https://github.com/systemed/potlatch2/commit/8f86250febf8be97cebf5112b076bd39e9fb4dea as penance for my being a miserable old sod.

I'd like to pretend that fixing this required hours upon hours of rooting through the Flex code. Actually this was one of those fixes where you think "hmmm, wonder if this might work on the off-chance" and it does, first time.

Note: See TracTickets for help on using tickets.