Ticket #3860 (reopened defect)

Opened 3 years ago

Last modified 13 months ago

Potlatch 2.2 does not discard a way's first point when Undo-ing it

Reported by: Pepou Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc: malenki

Description

Click two or more points (=n) on map - a way connecting clicked points is being created. After (n-1) Undo's the way is gone, but the initial point still remains visible (a green dot) and the Undo button is already grayed out - one step got forgot.

It is possible to delete the point manually (red (x) button), but it should be also deleted by the n-th Undo.

Change History

comment:1 Changed 3 years ago by Nop

  • Priority changed from minor to major

I observe this behaviour regularly. All that's needed is to create a two-node way and press undo once. This happens quite frequently when I try to drag the visible area but somehow P2 recognizes clicks instead of the drag. I think this is a major nuisance as it tends to create nonsensical empty nodes if you don't spot the problem and delete them manually. Does it break the undo system if such ghost objects are left over?

comment:2 Changed 2 years ago by stevage

  • Status changed from new to closed
  • Resolution set to fixed

Fixed. Ow. That was a lot harder than I expected.

 https://github.com/systemed/potlatch2/pull/33

comment:3 Changed 2 years ago by Pepou

Thanks, it was indeed a frequent nuisance.

comment:4 Changed 14 months ago by malenki

  • Cc malenki added
  • Status changed from closed to reopened
  • Resolution fixed deleted

The misbehaviour is still/again there. Node cannot be deleted using either undo-button or ctrl-z

comment:5 Changed 14 months ago by stevage

Yes. Although I submitted a pull request with the bug fix, it has not been accepted by the maintainer of Potlatch 2, Richard Fairhurst. I suggest you ask him politely about it.

comment:6 Changed 13 months ago by malenki

#4406 seems a duplicate of this bug.

Last edited 13 months ago by malenki (previous) (diff)
Note: See TracTickets for help on using tickets.