Opened 8 years ago

Closed 8 years ago

#3893 closed defect (fixed)

Potlatch crash when editing/adding tags

Reported by: banoffee Owned by: potlatch-dev@…
Priority: critical Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

I've been caught out by this several times - usually when I've got a bunch of unsaved changes :(

I've managed to get a reliable (for me) set of steps to reproduce, even if it's not a minimal test case:

  1. Load potlatch.
  2. Draw a new closed way.
  3. From the presets menu, select "Transport" section, and "Car Parking".
  4. Click 'Advanced' at bottom. Then 'Add' for a key
  5. Type 'access', <tab> 'perm', select "permissive" from auto-complete menu.
  6. Press 'Add' again, type 'name', <tab> <backspace>

(at this point, there is a key called 'name' with no value)

  1. Click where it says 'name', (e.g. to try and change to a different key such as 'operator')

Expected result: focus changes to key name, allowing this to be changed.

Actual result: Potlatch crashes, losing any work done since last save.

(undoubtedly there are other triggers, as I've stumbled into similar potlatch crashes several times, but the above steps did it every time for me from a fresh start)

Change History (2)

comment:1 Changed 8 years ago by jetthe

Version: 2.0

The crash is avoided by applying this patch: https://github.com/jetthe/potlatch2/commit/f3e46cc17dea55d98c0096a3ad5611e96f0cac7f

It doesn't solve the various focus issues in the simple and advanced tabs but at least it keeps P2 from going into an infinite loop when a key with no value is selected.

comment:2 Changed 8 years ago by jetthe

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.