Opened 7 years ago

Closed 5 years ago

#3985 closed enhancement (wontfix)

Add rendering for areas tagged waterway=dam

Reported by: drnoble Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: waterway, dam, render Cc:

Description

Mapnik does not appear to render areas tagged as waterway=dam, although it does render on ways. This means smaller dams show up, but larger more detailed mapping does not. The Wiki page http://wiki.openstreetmap.org/wiki/Dam suggests a rendering of black outline with grey hatching, suggesting this might be a regression from a previous implementation

Similar to ticket #1985 but not a duplicate

Osmarender shows waterway=dam on an area as a thick black line e.g. http://www.openstreetmap.org/?lat=55.90788&lon=-4.72763&zoom=17&layers=O

Change History (3)

comment:1 follow-up: Changed 6 years ago by katpatuka

this ticket is open now for 14 months...!

comment:2 in reply to: ↑ 1 Changed 5 years ago by RicoZ

Replying to katpatuka:

this ticket is open now for 14 months...!

... and another 13 months now...

Would be really nice if it would work.

comment:3 Changed 5 years ago by pnorman

  • Resolution set to wontfix
  • Status changed from new to closed

The "mapnik" component in trac is for the old XML-based openstreetmap.xml stylesheets which are not deployed on OpenStreetMap.org. Since June the default style on OpenStreetMap.org has been openstreetmap-carto, which has its own issue tracker at https://github.com/gravitystorm/openstreetmap-carto/issues.

I'm going to go ahead and close this issue as wontfix to avoid people being confused by it and commenting on it instead of somewhere where it will effect the rendering on osm.org. Closing it doesn't mean the issue won't be fixed in openstreetmap-carto, just that this ticket is against old unmaintained software that has been replaced and this ticket has zero chance of being resolved.

There is an openstreetmap-carto ticket requesting a distinction between unpaved and paved surfaces at https://github.com/gravitystorm/openstreetmap-carto/pull/227, but please read the roadmap at https://github.com/gravitystorm/openstreetmap-carto#roadmap to understand what issues are an immediate priority.

Note: See TracTickets for help on using tickets.