Ticket #3987 (closed defect: invalid)

Opened 3 years ago

Last modified 19 months ago

can't create table - ERROR: type "hstore" does not exist

Reported by: hadmut@… Owned by: brett@…
Priority: minor Milestone:
Component: osmosis Version:
Keywords: Cc:

Description

Hi,

I am trying to create a new database under postgresql 9.1rc1 with osmosis 0.39 and

psql -d osm -f pgsnapshot_schema_0.6.sql

getting the error message psql:pgsnapshot_schema_0.6.sql:52: ERROR: type "hstore" does not exist

Change History

comment:1 Changed 3 years ago by hadmut@…

When trying it the other way, i.e.

psql -d osm -f pgsimple_schema_0.6.sql psql -d osm -f pgsnapshot_schema_0.6_upgrade_5-6.sql

I get the error message

Caused by: org.postgresql.util.PSQLException: ERROR: column "tags" of relation "nodes" does not exist

and pgsimple_schema_0.6.sql allone cannot be used since schema_info=5 is not accepted by osmosis

comment:2 Changed 3 years ago by species

Is hstore enable for the postgres user owning the database? you can view enabled extensions with: sudo -u postgres psql -U gis # where "gis" is the owner of the DB you want import into SELECT * FROM pg_available_extensions ;

i had the same problem with osm2pgsql and psql9.1rc1, and after CREATE EXTENSION hstore; as the user owning the DB (hat to set him superuser before) the import worked.

comment:3 Changed 3 years ago by hadmut@…

Yup, CREATE EXTENSION solved the problem.

They had changed the way to create extensions in postgresql 9.1 without documenting it.

So all those HowTos? about how to create an OSM database are wrong in this aspect if a newer version of pgsql is used.

comment:4 Changed 19 months ago by stephankn

  • Status changed from new to closed
  • Resolution set to invalid

no problem with osmosis, documentation is a wiki...

Note: See TracTickets for help on using tickets.