Opened 8 years ago

Closed 7 years ago

#3988 closed defect (fixed)

osm2pgsql: missing include

Reported by: amdmi3@… Owned by: jburgess777@…
Priority: critical Milestone:
Component: osm2pgsql Version:
Keywords: osm2pgsql Cc:

Description

At least on MacOSX Lion:

--- /usr/bin/cc -std=gnu99 -DHAVE_CONFIG_H -I. -D_THREAD_SAFE -pthread -I/usr/local/Cellar/postgresql/9.0.4/include -I/usr/include/libxml2 -I/usr/include -I/usr/local/Cellar/geos/3.3.0/include -I/usr/local/include -DOSM2PGSQL_DATADIR='"/usr/local/share/osm2pgsql"' -Igeos-fallback -D_THREAD_SAFE -pthread -I/usr/local/Cellar/postgresql/9.0.4/include -I/usr/include/libxml2 -I/usr/include -I/usr/local/Cellar/geos/3.3.0/include -I/usr/local/include -DOSM2PGSQL_DATADIR='"/usr/local/share/osm2pgsql"' -DVERSION='"0.80.0"' -O3 -march=core2 -msse4.1 -w -pipe -MT keyvals.o -MD -MP -MF .deps/keyvals.Tpo -c -o keyvals.o keyvals.c In file included from middle.h:10,

from output.h:13, from expire-tiles.h:4, from expire-tiles.c:16:

osmtypes.h:45: error: expected specifier-qualifier-list before ‘time_t’ make[2]: * [expire-tiles.o] Error 1 ---

See: https://github.com/mxcl/homebrew/issues/6399#issuecomment-1956169

Reported to be fixed by adding #include <time.h> into osmtypes.h:

https://github.com/AMDmi3/osm2pgsql/commit/aa7fa00ab4464a83fa6ea1933bb4353be3cea39d

Change History (4)

comment:1 Changed 8 years ago by Tom Hughes

Owner: changed from Tom Hughes to jburgess777@…
Status: newassigned

comment:2 Changed 8 years ago by Tom Hughes

Component: utilsosm2pgsql

comment:3 Changed 8 years ago by amm

I have committed the patch. If the problem is fixed for you, could you please mark the bug as closed?

comment:4 Changed 7 years ago by amm

Resolution: fixed
Status: assignedclosed

As there was no further activity, closing

Note: See TracTickets for help on using tickets.