Opened 7 years ago

Closed 7 years ago

#3991 closed enhancement (duplicate)

Too easy to align nodes

Reported by: Pieren Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version: 2.0
Keywords: align Cc:

Description

We find more and more altered data done by newcomers playing with P2 and aligning by "accident" nodes. The problem is prominent for long ways going outside the editor screen, e.g. coastlines, rivers, motorways or railways. One the newcomer presses the 'align nodes' command, the selected way may disappear from the screen and people do not notice the damage. It would nice to display some warnings when someone algns nodes and result is not visible on the screen anymore.

Change History (1)

comment:1 Changed 7 years ago by Richard

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of some other ticket, I forget which. Anyway, a future version will hide the bottom row of the toolbox with a disclosure triangle which should largely eliminate this. I think P1 used to only align on-screen nodes and that might be worth considering for P2 too.

Note: See TracTickets for help on using tickets.