Opened 8 years ago

Closed 5 years ago

#3996 closed defect (worksforme)

[water] Ferry and river name only partially rendered o zoom 16 to 18

Reported by: Seoman Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

The names of a ferry ("Hafenrundfahrt Duisburg") and a river ("Rhein") lying next to each other on zoom levels 16 to 18 are only partially rendered. Interestingly though, the river name is rendered correctly on levels 16 and 18, but incomplete on level 17 - and the ferry name just vice versa: correctly on level 17, but incomplete on levels 16 and 18. I take it there might be a connection?

http://www.openstreetmap.org/?lat=51.426765&lon=6.723458&zoom=18&layers=M

http://www.openstreetmap.org/?lat=51.42677&lon=6.72401&zoom=17&layers=M

http://www.openstreetmap.org/?lat=51.42737&lon=6.72288&zoom=16&layers=M

Additional note: I'm not sure about this: the administrative boundary just next to this is between "Mitte" and "Rheinhausen". But "Mitte" is only rendered at levels 17 and 18. Is this the correct behaviour?

Change History (3)

comment:1 Changed 8 years ago by Ldp

The cut off labels are rendering artifacts at metatile boundaries.

The missing "Mitte" might be dropped due to "Rheinhausen" being rendered first, at the same spot. This can vary by zoom level.

comment:2 Changed 5 years ago by math1985

Summary: Ferry and river name only partially rendered o zoom 16 to 18[water] Ferry and river name only partially rendered o zoom 16 to 18

comment:3 Changed 5 years ago by math1985

Resolution: worksforme
Status: newclosed

I cannot reproduce this. If it occurs again, please open a new issue at https://github.com/gravitystorm/openstreetmap-carto/.

Note: See TracTickets for help on using tickets.