Opened 8 years ago

Closed 6 years ago

#4029 closed defect (wontfix)

osmarender vs Mapnik formats result in different latitudes for north edge of map

Reported by: james_7114737 Owned by: Tom Hughes
Priority: minor Milestone:
Component: admin Version:
Keywords: latitude osmarender mapnik Cc:

Description

Greetings,

This is my first post, please bear with me.

I've noticed that when generating map data from http://openstreetmap.org, that there appears to be some inconsistency with the latitude when exporting maps in different formats.

For example, if I export a map of Northern Ontario, Canada with manually entered coordinates:

57

-95.2 -79.5

52


  1. first in Mapnik format (png, 3050000)
  1. then in Osmarender format (png, 7)

the two maps obviously differ in latitude: the osmarender map is further south. The differences are I believe mathematically significant. Map file outputs are attached.

I personally am most concerned about the coordinate accuracy of the Osmarender generation. Generating different Osmarender images at different Zooms gives a consistent approach to latitude, which is a good thing! 8-)

  1. Ubuntu linux 10.04, Firefox 3.6.23
  1. http://openstreetmap.org Export feature
  1. step by step

3a open http://openstreetmap.org in firefox

3b click on Export button

3c click on Export button again to see N W E S text entry boxes

3d enter values above into respective coordinate text boxes

3e click on MapnikImage?

3f enter maximum scale (2350000)

3g click Export, save image to disk (osm_nnontario_mapnik_2350000.png)

3h click OsmarenderImage?

3i select Zoom of 7

3j click Export, save image to disk (osm_nnontario_osmarender_7b.png)

3k open both images and compare

4 Expected both images to cover the same coordinates.

5 Osmarender map is further south than Mapnik. Unsure which is at correct latitude.

CU,
james

Change History (9)

comment:1 Changed 8 years ago by james_7114737

Both images generated are larger than the attachment limit so could not attach. Grrr.

comment:2 Changed 8 years ago by Tom Hughes

So which one matches the area you asked for? Without knowing that I have no way who is at fault and who I should assign this bug to.

comment:3 in reply to:  2 Changed 8 years ago by james_7114737

Replying to TomH: Greetings. I picked the first anonymous upload site from a search engine. The site changes the image sizes and type unfortunately...

Mapnik [http://www.picvalley.net/v.php?p=u/2286/46757639911465586711317444445ODRLFMQHs7ctFTtPFZmc.PNG ]


Osmarender is further south http://www.picvalley.net/v.php?p=u/2359/88656530196261351213174445499YRrpl1Ts3WLXHc38pEt.PNG


I would recommend generating the maps off the website as well to ensure it isn't a browser issue of some sort and that the issue is reproducible.

comment:4 Changed 8 years ago by Tom Hughes

None of which answers my question as to which of them is correct... Surely you must know what area you had selected and therefore which image is correct?

comment:5 Changed 8 years ago by Tom Hughes

Resolution: wontfix
Status: newclosed

Well because it's such a massive and empty area it's hard to be sure which is correct, but my guess is mapnik because it renders the exported map from scratch so it should be exact.

The osmarender one is using a third party tile stitching service so may well be rounding things to tile boundaries which likely explains the difference. It would be much easier to tell if it was a smaller and more detailed area.

Either way I don't see a major problem here.

comment:6 Changed 8 years ago by rw__

Resolution: wontfix
Status: closedreopened

find the original sample images here http://imgur.com/a/vViKF

The southern bound in the sample images does not match the BBox above. I wonder if the southern was actually "48"? If so, the mapnik version a very good match for the bbox on the osm.org export tab.

I requested both mapnik and osmarender images with those modified bounds and find results similar to james'. The mapnik image matches the bbox shown on osm.org. The osmarender image seems to have slipped south a bit (misses some of the north bound but shows more map below the southern bound).

The images from this test can be found here. http://imgur.com/a/LNc5L#0Ix5n

When I tested a small area at z18, both mapnik and osmarender showed the expected area.

Not sure if this is an issue at all, or an issue for osmarender or osmarender_frontend. Feel free to close again if this information is insufficient.

comment:7 in reply to:  4 Changed 8 years ago by james_7114737

Replying to TomH:

None of which answers my question as to which of them is correct... Surely you must know what area you had selected and therefore which image is correct?

I generate two maps with the same coordinates using the steps above, and "one of these things doesn't look like the other." I would have to drive for 20 hours and fly for 6 to get a GPS fix on the northern edge of the map to be able to tell you which is correct. I am just an end user - how do you expect me to identify the correct one? Maybe both are slightly incorrect, one south and one north.

The fact that they are visibly different means that there is an issue. If it is a tiling issue of some sort so that the data requested isn't exactly the data generated, presenting the web user with the actual bounding coordinates of the map generated would be a sufficient workaround IMHO.

comment:8 Changed 8 years ago by james_7114737

Generated two maps of Thunder Bay at higher resolution: issue exists here too IMHO, but the latitude delta is much less perceptible. Exporting map from http://openstreetmap.org export tab as before:

N=48.49

W=-89.35 E=-89.11

S=48.33

Mapnik, 1:50000 http://www.picvalley.net/v.php?p=u/1942/65935886020252696901317532639ooXIX5skMZRwKxhLWhw3.PNG

Osmarender with same BBOX coordinates, zoom 13: http://www.picvalley.net/v.php?p=u/1584/12001632959177851301317532737ccQSTGMKF3NJEDmMvuBu.PNG

If you zoom into the top left corner of each map (say 800%), you can again tell that the north latitude is different. The delta is much much less, probably not mathematically significant - most end users wouldn't notice the difference. In the larger coverage map, the difference is mathematically significant, which is why I took the time to let you folks know!

comment:9 Changed 6 years ago by iandees

Resolution: wontfix
Status: reopenedclosed

Cleaning old tickets.

Note: See TracTickets for help on using tickets.