Ticket #4032 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Typing value of name goes to begining

Reported by: maxolasersquad Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

When updating the value of a name key, after the first letter is entered the cursor goes to the beginning of field.

Change History

comment:1 Changed 3 years ago by TomH

What software exactly are you typing this into? Potlatch? JOSM?

comment:2 Changed 3 years ago by TomH

  • Owner changed from tom@… to potlatch-dev@…
  • Component changed from admin to potlatch2

I assume, given you raised #4031 at the same time, that this is about Potlatch 2.

comment:3 Changed 3 years ago by Richard

Adobe have changed a lot of the TextInput? architecture in Flex 4.5 and unfortunately it no longer works reliably with our AutoComplete? component. I've spent a while trying to fix it but it looks non-trivial. Essentially the problem is that line 212 here ( http://git.openstreetmap.org/potlatch2.git/blob/HEAD:/net/systemeD/controls/AutoComplete.as) isn't setting the insertion point location as it ought to (and used to).

We could consider moving to another AutoComplete? component:  http://flashcommander.org/blog/flex-4-autocomplete,  http://www.unitedmindset.com/jonbcampos/2010/05/12/creating-custom-spark-components/,  http://hillelcoren.com/flex-autocomplete/ .

comment:4 Changed 3 years ago by Richard

  • Status changed from new to closed
  • Resolution set to fixed

Actually - fixed in  https://github.com/systemed/potlatch2/commit/f15d9bcea0abbbfff2b087bcecfbe8cefb6e976e by the time-honoured practice of: if it's not doing what it should, use the magic Flex incantation someUIComponent.validateNow(), which might as well be renamed someUIComponent.workGoddamit().

Note: See TracTickets for help on using tickets.