Opened 8 years ago

Closed 6 years ago

#4041 closed defect (wontfix)

install-postgis-osm-db.sh not work on PostgreSQL9.1

Reported by: max@… Owned by: jburgess777@…
Priority: minor Milestone:
Component: osm2pgsql Version:
Keywords: Cc:

Description

1) "/usr/share/postgresql/[PG_VERSION]/contrib/" is deprecated, it's a Debian only specific path. Need "/usr/share/postgresql/contrib/"

2) createlang plpgsql always return error on pgsql 9.1, because plpgsql is already installed in database by default. Need "
true" to end of command

Attachments (1)

osm2pgsq-install-db.patch (1.3 KB) - added by max@… 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by max@…

Attachment: osm2pgsq-install-db.patch added

comment:1 Changed 8 years ago by max@…

3) Script use unset variable DBNAME, and psql use DB postgres.

comment:2 Changed 8 years ago by amm

There is a slightly updated version of the script in svn. It handles PostgreSQL 9.1 and the fixes the plpgsql issue.

However, 9.1 and 8.4 need to be handled differently. Without the PG_VERSION in the path, how is one supposed to determine which version of postgres is running from bash?

comment:3 Changed 6 years ago by amm

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.