Opened 8 years ago

Closed 8 years ago

#4047 closed defect (invalid)

rendering of meadow in cascading multipolygon relations

Reported by: bbauer Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

I have here two multipolygon relations stacked within each other. The outermost one is a landuse=forest area where there is a landuse=meadow as inner part. The meadow is at the same time outer part of a second multipolygon. Furthermore the boundary of this meadow is not a single closed way, but consists of several ways, some of them highways.

If you look a this construct at zoom 14, all is rendered as intended, which means the meadow has its usual green color:

http://www.openstreetmap.org/?lat=48.9671&lon=12.8354&zoom=13&layers=M

Also at zoom 18, all is fine:

http://www.openstreetmap.org/?lat=48.9664&lon=12.836046&zoom=18&layers=M

But for the zoom levels inbetween the meadow is not rendered which means, its just a "gey hole" in the forest area.

Change History (2)

comment:1 Changed 8 years ago by bbauer

Addon: I just saw, that one of the inner objects of the meadow multipolgon cut the meadow area into two pieces and only one of them got rendered on zoom levels 15-16.

But this raises the question, why it worked on the other zoom levels?

comment:2 Changed 8 years ago by Ldp

Resolution: invalid
Status: newclosed

There's no such thing as a stacked multipolygon relation in OSM. It may appear that way, but apart from sharing one ring they're on their own.

And it's the same to the renderer. The fact that you saw a grey hole at some zooms, and the cut-in-half appearance, is due to the fact that apparently those hadn't rendered yet. The current appearance (fine on all zooms) supports this.

Note: See TracTickets for help on using tickets.