Opened 8 years ago

Closed 7 years ago

#4072 closed defect (fixed)

Tagging a way freezes tagging menu

Reported by: Mark Pulley Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

I can add as many ways as I like without problems, but once I add tags to a way, the menu on the left freezes.

If I am using 'simple': once I select a road type, the drop-down menu remains down. I can move it back up by clicking on the tab, but if I click anywhere previously covered by the drop-down menu, the menu reappears. I can add new ways, and categorise them differently as long as it appears in the same section (e.g. if the first way is highway=trunk, I can select other types of road, but not switch to (e.g.) rail). The advanced tab no longer works, so I can't add other tags.

If I am using 'advanced': again I can add as many ways as I like, but once I create some tags, I am stuck using just this way - any clicks on the map adds a new node on the same way, double-clicking or deleting don't work. I can finish the way by pressing enter, but I can't then create any more ways or select the original way. (I can still drag nodes onto the map.)

I initially was using Bing imagery, I've turned this off to no effect.

I first noticed this on my 6-year old Mac at home, I initially thought it was because of my dial-up connection (slow, maybe not completely loading), but it is also happening on my new Windows 7 computer at work, broadband connection.

Change History (5)

comment:1 Changed 8 years ago by Richard

Not seen this before - it sounds like it could be a problem specific to the area you're editing. Could you post the URL and exact steps to reproduce at that location?

I strongly suspect that Flash is throwing an exception somewhere in this process - if you have the time to help pin it down, http://wiki.openstreetmap.org/wiki/Potlatch_2/Using_Flash_Debug_Player will show you how to find out, giving a detailed bug report we can use to help fix it.

comment:2 Changed 8 years ago by Mark Pulley

Here's my last few relevant changesets (all in New South Wales, Australia): http://www.openstreetmap.org/browse/changeset/9025915 - Dubbo - this was my last successful edit with Potlatch 2 from August 2011. The next few have the problem: http://www.openstreetmap.org/browse/changeset/9468029 - Premer (Oct 4) http://www.openstreetmap.org/browse/changeset/9640800 - near Cowra (Oct 24) http://www.openstreetmap.org/browse/changeset/9690236 - Premer (Oct 30)

I tried deleting the internet cache, but the problem persists. I have just tried an edit in Dubbo (previously no problem here), but the same problem is happening here as well.

Here's some URLs: near Cowra: http://www.openstreetmap.org/?lat=-33.7635&lon=148.85598&zoom=17 Premer: http://www.openstreetmap.org/?lat=-31.45489&lon=149.89883&zoom=16 Dubbo: http://www.openstreetmap.org/?lat=-32.246334&lon=148.592976&zoom=18

comment:3 Changed 8 years ago by Mark Pulley

The problem must have something to do with Flash. I've just updated the work computer (Windows 7) to the latest version of Flash, and Potlatch 2 seems to be working perfectly. I haven't had the chance to test my home computer (MacOS), but I suspect that this will be fixed also with a Flash update.

comment:4 Changed 7 years ago by migurski

This occurs even when just clicking on a way or node for me; see ticket:4164.

comment:5 Changed 7 years ago by Richard

Resolution: fixed
Status: newclosed

osm.org now correctly detects the version of Flash required.

Note: See TracTickets for help on using tickets.