Opened 8 years ago

Closed 8 years ago

#4082 closed defect (fixed)

Simple mode menus stay open after click that changes selection

Reported by: StellanL Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version: 2.0
Keywords: popup menu Cc:

Description

The popup menus in simple mode need to be clicked twice to close.

Steps to reproduce: Draw a way. Make it any road type, e.g. residential. Click the "Oneway" menu in the Basic tab. Menu appears with 4 choices. Click "One way"; the selected value changes on the tab and in the map, but menu stays open. Click "One way" again; now the menu closes.

Behavior seems to be: 1.Before you have clicked a menu choice, menu can be dismissed by clicking anywhere outside the menu. (Good) 2.If you click the currently selected choice, the menu also closes on the 1st click. (Good) 3.If you click a new choice, it takes effect immediately, but menu stays up. (Wrong) 3a. If the second click is on the now-current selection, the menu closes. 3b. If the second click is on another choice, it does not take effect, but menu sometimes stays up. A third click is then needed to close the menu. (Really annoying)

Potlatch version: 2.3-88-gc431f56 Environment: Windows XPSP3, Firefox 7.0.3, Flash 10.3.183.7

Change History (1)

comment:1 Changed 8 years ago by StellanL

Resolution: fixed
Status: newclosed

Seems to be fixed in 2.3-89

Note: See TracTickets for help on using tickets.