Opened 7 years ago

Closed 5 years ago

#4084 closed task (fixed)

Update boundaries from NaturalEarth

Reported by: Ohr Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

The Mapnik map at zoom levels 1 to 3 does not show South Sudan yet. After some searching this probably is caused by outdatet administrative boundaries from Naturalearth.

So I would kindly ask to update the 110m admin 0 data set to the latest version available at Naturalearth.

Change History (6)

comment:1 Changed 7 years ago by skorasaurus

Resolution: fixed
Status: newclosed

Can confirm this bug being still exists. South Sudan as administrative boundary now currently exists (level 2) as OSM data. http://www.openstreetmap.org/browse/relation/1656678 The name renders but the border does not.

My first guess is that the ways [example http://www.openstreetmap.org/browse/way/136107215 ] has multiple relations, the level 2 admin boundary, and a level 4 relation on it.http://www.openstreetmap.org/browse/relation/2190484

Toebee believes that the z0-3 the data doesn't come from OSM, but from a shapefile which may have been what you were referring to - https://trac.openstreetmap.org/browser/subversion/applications/rendering/mapnik/get-coastlines.sh#L46

the 110m_admin_0_boundary_lines contains only inland country borders and no coastline. world_boundaries_m has country borders including coastline and world_bnd_m has the same but tiled

Last edited 7 years ago by skorasaurus (previous) (diff)

comment:2 Changed 7 years ago by skorasaurus

Resolution: fixed
Status: closedreopened

comment:3 Changed 7 years ago by ToeBee

Yep. z0 doesn't have any country borders. Borders at z1-3 actually come from the file downloaded at line 50 instead of 46 like I thought at first in get-coastlines.sh:

http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/110m/cultural/110m-admin-0-boundary-lines.zip

So technically this isn't really an OpenStreetMap problem but a naturalearth problem. The only thing OSM could do would be to stop using this naturalearth shapefile and produce our own instead like we do with coastlines.

About the only thing I can suggest in the mean time is using the "Find a problem?" link on the naturalearth site. They haven't put out a new version since 2009 so maybe if enough people bug them, they will get around to it. This file is available from:

http://www.naturalearthdata.com/downloads/110m-cultural-vectors/110m-admin-0-boundary-lines/

comment:4 Changed 7 years ago by ajashton

The latest version of Natural Earth was released in August 2012 [1] and includes South Sudan among other updates. The version history on that link is out of date - the shapefile download is not.

It may be worth just waiting a few days though as I believe an even newer release of Natural Earth is imminent [2]

[1]: http://www.naturalearthdata.com/blog/natural-earth-version-1-4-release-notes/ [2]: https://twitter.com/kelsosCorner/status/255416186995609601

Version 0, edited 7 years ago by ajashton (next)

comment:5 Changed 6 years ago by Ohr

Well, the problem might be caused by a broken link in https://trac.openstreetmap.org/browser/subversion/applications/rendering/mapnik/get-coastlines.sh#L50

Currently the script uses 110m-admin-0-boundary-lines.zip as the file name while the Natural Earth page points to a file called ne_110m_admin_0_countries.zip.

By the way, the same problem applies to the populated places downloaded in the line above which should be ne_10m_populated_places.zip according to the corresponding Natural Earth page.

comment:6 Changed 5 years ago by Andy Allan

Resolution: fixed
Status: reopenedclosed

The boundaries have been updated in the meantime, and South Sudan shows up on the tileserver.

Note: See TracTickets for help on using tickets.