Opened 8 years ago

Closed 8 years ago

#4091 closed defect (fixed)

wrong delete items in osmChange XML

Reported by: arcth Owned by: rails-dev@…
Priority: minor Milestone:
Component: api Version:
Keywords: osmChange XML node delete Cc: DrScott

Description

osmChange XML at http://www.openstreetmap.org/api/0.6/changeset/9761539/download contains 4 delete of the same node which was not edited in this changeset:

<delete>
<node id="2" lat="50.1360088" lon="8.3023703" changeset="484067" user="PHerison" uid="28378" visible="true" timestamp="2008-05-20T07:47:29Z" version="2">
<tag k="name" v="Naurod"/>
<tag k="created_by" v="Potlatch 0.9a"/>
<tag k="is_in" v="Wiesbaden;Hessen,Germany,Europe"/>
<tag k="place" v="village"/>
</node>
</delete>

Change History (2)

comment:1 Changed 8 years ago by DrScott

Cc: DrScott added

This problem seems to be reproducable with any changeset. Beneath id 2, id 3 is also affected.

comment:2 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

Fixed - should be live shortly.

Note: See TracTickets for help on using tickets.