Opened 8 years ago

Closed 8 years ago

#4104 closed defect (fixed)

Unable to delete trace

Reported by: tonyb@… Owned by: Tom Hughes
Priority: major Milestone:
Component: admin Version:
Keywords: Cc:

Description

For the past 2 weeks or so, unable to delete trace using the web interface. Tried 3 different browsers (IE, Chrome, FF) and cleared cache/history and still fail.

Steps to reproduce: 1) Login 2) go to GPS Traces -> See your Traces 3) pick a trace to delete by clicking "more" and then "delete this trace" 4) The next webpage displayed is the login page again. Proceed and try to login again. 5) Get redirected to http://www.openstreetmap.org/trace/1141819/delete but the actual delete never happens.

Change History (2)

comment:1 Changed 8 years ago by Tom Hughes

I can't reproduce this myself, and there's nothing much in the logs from your attempts that helps.

So I have added some extra logging to the code which I suspect is causing the problem and deployed that. Can you please try again and then let me know, including the URL or ID of the trace you tried to delete.

Thanks.

comment:2 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

I've got to the bottom of this now...

In summary the problem only existed when (a) caching was enabled and (b) you were logged in as a non-administrative user.

Unfortunately (a) meant it would never happen in my development environment and (b) meant it didn't happen for me even in the production environment...

It should be fixed now anyway.

Note: See TracTickets for help on using tickets.