Opened 8 years ago

Closed 8 years ago

#4119 closed defect (fixed)

Answering to mails sent through messages.openstreetmap.org not correctly paresd when using MIME emails with multipart/alternative

Reported by: Kurt Krampmeier Owned by: rails-dev@…
Priority: major Milestone:
Component: website Version:
Keywords: Cc:

Description

Answering a mail, that was sent through the OSM message system (e. g. <http://www.openstreetmap.org/message/new/Kurt%20Krampmeier>), causes unwanted results for the reader, when the reply is a multipart/alternative email. Creating multipart/alternative email is unfortunately the default setting in many popular mail clients and web mailers.

In such cases, the whole mail body (both parts in their transfer encoding along with their headers and boundaries) is interpreted as the message text. So a simple answer like "Hello World!" might show up as

"This is a multi-part message in MIME format.


Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit

Hello World!


Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: 7bit

&lt;!DOCTYPE HTML PUBLIC &quot;-W3CDTD HTML 4.01 TransitionalEN&quot;&gt; &lt;html&gt;

&lt;head&gt;

&lt;meta content=&quot;text/html; charset=UTF-8&quot; http-equiv=&quot;Content-Type&quot;&gt;

&lt;/head&gt; &lt;body bgcolor=&quot;#ffffff&quot; text=&quot;#000000&quot;&gt; Hello World! &lt;/body&gt;

&lt;/html&gt;


The wrong use of HTML entities shown in this example is caused by another bug: http://trac.openstreetmap.org/ticket/4118

Change History (2)

comment:1 Changed 8 years ago by Kurt Krampmeier

Trac has replaced the boundary lines by thin gray horizontal rules. The result is still bad enough to show the problem clearly.

comment:2 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

Fixed - we now only use one part. Will be deployed shortly.

Note: See TracTickets for help on using tickets.