Opened 8 years ago

Closed 8 years ago

#4150 closed defect (fixed)

sv-SE locale displays nodes Lon & lat without separator

Reported by: emj Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: i18n swedish Cc:

Description

  1. set local sv
  1. goto http://www.openstreetmap.org/browse/node/666041980
  1. it displays like this:

Koordinater: 593171204, 180332574

it should display like this:

Koordinater: 59,3171204, 18,0332574

This does not affect other locales that use "," such as fr. I tested about 32 locales and I've only seen this bug on the sv locale.

The code being run is line 7 in app/views/browse/_node_details.html.erb:

number_with_delimiter(node_details.lat)

Change History (2)

comment:1 Changed 8 years ago by Tom Hughes

The causes this are quite complicated, and the real root problem is that we have have an "sv" translation but rails was an "sv-SE" translation, which is going to be a little tricky to deal with.

We should at least be falling back to the english rules though, which we would do but for a bug in the i18n gem which is fixed here:

https://github.com/svenfuchs/i18n/commit/37465428732e8ffe425214d2a867de802e560303

Unfortunately there hasn't been a new release since then so I'll have to try and monkey patch it.

comment:2 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

This should be fixed now, and will be deployed shortly.

Note: See TracTickets for help on using tickets.