Opened 8 years ago

Closed 6 years ago

#4165 closed defect (fixed)

Adding OpenID URL makes log in impossible

Reported by: emj Owned by: rails-dev@…
Priority: critical Milestone:
Component: website Version:
Keywords: openid login Cc: fernando82@…

Description

  1. create a new user
  2. add an openid url
  3. save

Result:

You are logged out and logging in with password doesn't work. I tested this with the user fake_123 and password fake_123.

See:

http://help.openstreetmap.org/questions/9623/how-can-i-log-in-to-openstreetmaporg

http://help.openstreetmap.org/questions/9631/cant-log-in

Note I could do more work on this report, but I need sleep.

Change History (5)

comment:1 Changed 8 years ago by emj

More problems, and a fix

  1. add a openid url to an account
  2. you get logged out

result: Login will not work, for any account.

Fix: removing cookies for openstreetmap.org will help.

comment:2 Changed 8 years ago by fernando82@…

Cc: fernando82@… added

comment:3 Changed 8 years ago by amm

This is a very odd bug. It appears to sometimes work and sometimes doesn't. With the same code, the bug is sometimes reproducable on a test instance while it works on osm.org and vice versa.

From what I have been able to track down, the problem appears to be originating outside of our code and somewhere in the middleware of rails. The session db gets corrupted and looses the relevant information during the OpenID redirect, resulting in the logged out user. Given the intermittent nature of the issue, my guess would be some form of race condition, but I haven't been able to debug this any further as I don't know how to debug the session store middleware.

When I tried this a couple of weeks ago on osm.org, adding a OpenID, however, worked correctly again. Do others still see this problem? Did it recently start again?

comment:4 Changed 7 years ago by Tom Hughes

I suspect this was caused by openid state data not being shared properly across all the machines, which was fixed by this commit:

http://git.openstreetmap.org/rails.git/commit/f89dda9b906706da007e8185e8ffcd8a65ebac36

Is anybody still seeing this problem now?

comment:5 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

We haven't had any more complaints so I assume I was right about this now being fixed.

Note: See TracTickets for help on using tickets.