Opened 7 years ago

Closed 5 years ago

#4254 closed defect (fixed)

don't render the name of power lines tagged layer=-1

Reported by: DrScott Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: underground power cable layer Cc:

Description

Power cables which are tagged layer=-1 are not rendered by mapnik. This is good. But unforunately: If a name exists, it gets rendered along that invisible line. This is confusing.

Example: http://www.openstreetmap.org/browse/way/143902497

http://www.openstreetmap.org/?lat=49.454935&lon=11.114777&zoom=18&layers=M Look at "Bauhof - Rehhof - Wöhrder Tor" in the middle of the map.

Same power line, other location: http://www.openstreetmap.org/?lat=49.459255&lon=11.140326&zoom=18&layers=M Here only part of the name is rendered: "of - Wöhrder Tor"

Change History (1)

comment:1 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The catch-alls that were the cause of many of these names have been removed.

Not to mention, if it's power=line or power=minor_line, it's a power line and there's nothing wrong with rendering it as such...

Note: See TracTickets for help on using tickets.