Opened 7 years ago

Closed 2 years ago

#4264 closed defect (duplicate)

Potlatch creating self overlapping roads

Reported by: Maetma Owned by: potlatch-dev@…
Priority: critical Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

Many new users add roads that are superposed with Potlatch. Create this roads should be forbidden by Potlacth. It takes a lot of time to fix.

Change History (10)

comment:1 Changed 7 years ago by Richard

Resolution: invalid
Status: newclosed

Not really a clearly expressed bug.

comment:2 Changed 7 years ago by stevage

My interpretation of this bug was that Potlatch should warn/prevent users making roads that cross each other ("superposed") without a junction. I've previously written the code to make this possible, so I actually think it's feasible.

comment:3 Changed 7 years ago by Richard

There is actually a (slightly better phrased) dupe of this by the same reporter, so we don't need both. It's certainly possible code-wise, that much is fairly obvious. It's the UI that's harder - we certainly don't want P2 to start randomly adding junction nodes when the user's very next action might be to add a bridge=yes tag. I suspect a better solution might be the long-planned data quality inspector, but it needs careful design.

comment:5 Changed 7 years ago by Maetma

Summary: Incorrect roadPotlatch creating self overlapping roads

In the case I am described the raod selfs overlapping.

In the majority of the cases the user clicks again on the before last node. The incorrect road is like this : node1 node2 node3 ... node(n-1) node(n) node(n-1)

He would not be possible to re-selecting node(n-1)

comment:6 Changed 7 years ago by stevage

Makes sense to prevent the user forming a way as described: 0, 1, 2, 3, 4, 3... Such a way seems extremely unlikely to be valid.

comment:7 Changed 7 years ago by maetma

Priority: majorcritical

Way as 1-2-1 must not be created

When delete 2 it gets way with one node in it this is wrong

comment:8 Changed 7 years ago by stevage

Is this definitely still happening? I did review this code recently. Do you have an example?

comment:9 Changed 3 years ago by illya2400

Here are some examples of ways that completely overlap themselves. In JOSM, the validation error is "way contains segment twice"

way 396166566 way 396189678 way 396185942

Ways were created by new user using Potlatch 2. The ways were created in February 2016, so this is still a major issue.

comment:10 Changed 2 years ago by Richard

Resolution: duplicate
Status: reopenedclosed

Duplicate of #4020.

Note: See TracTickets for help on using tickets.