Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4307 closed defect (invalid)

Weird behavior when changing tags (ie name_1=* to alt_name=*)

Reported by: compdude Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: weird, behavior, tag, change, advanced Cc:

Description

In Potlatch 2 when you are using the advanced view to edit tags for a particular way, there is something weird going on when you change the tag from one thing to something else.

So here is what was happening: In the text field where you define the name of the tag (the first column, not the second), I went ahead and changed something from "name_1=ABC" to "alt_name=ABC", and then hit enter. Instead of just changing the key to "alt_name=ABC" like normal, it instead changed it to "source=[blank value field]" where source is the tag listed after the "name_1" tag. Interestingly enough, if you then click the undo button, it will do what it's supposed to do and re-add the "alt_name=ABC" tag and everything will return to normal. I just noticed this today (March 17) when I was editing, and I'm not sure if this is also an issue with nodes.

At least there's a simple workaround for this bug, so it's not like it's urgent or anything. But it's still kind of annoying and may be harder for new users to figure out what's going on.

Finally, I am using Potlatch 2 in Firefox 10.0.2 on Windows XP service pack 3.

Hope this helps, and happy bug-fixing :) !

Thanks, Compdude

Change History (6)

comment:1 Changed 7 years ago by stevage

Hmm, I can't reproduce. What's the exact sequence of mouse clicks and keypresses? Does it only happen with tag values that have a B in them (since B is the shortcut for adding a source...)?

comment:2 in reply to:  1 Changed 7 years ago by compdude

Replying to stevage:

Hmm, I can't reproduce. What's the exact sequence of mouse clicks and keypresses? Does it only happen with tag values that have a B in them (since B is the shortcut for adding a source...)?

I was just using the source tag as an example. What exactly was happening was that I was doing TIGER fixup and I changed a name_1 tag to alt_name. And it instead was replacing it was the tag listed after the name_1 tag, which in this case happened to be tiger:tlid, I think. It happened several times in my editing session.

comment:3 Changed 7 years ago by stevage

Can you still reproduce it? If so, could you give a specific example of an object that this happens to, and a sequence of steps like:

  1. Click on object X with a name_1=foo tag
  2. Click on name_1 label
  3. ...

comment:4 in reply to:  3 ; Changed 7 years ago by compdude

Resolution: invalid
Status: newclosed

Replying to stevage:

Can you still reproduce it? If so, could you give a specific example of an object that this happens to, and a sequence of steps like:

  1. Click on object X with a name_1=foo tag
  2. Click on name_1 label
  3. ...

I tried it again on the same computer just now having updated firefox to version 11 from version 10 (why do they have to update it so often?) and It seems to be working fine. Obviously nothing was wrong with FF after all :)

comment:5 in reply to:  4 Changed 7 years ago by compdude

Replying to compdude:

Replying to stevage:

Can you still reproduce it? If so, could you give a specific example of an object that this happens to, and a sequence of steps like:

  1. Click on object X with a name_1=foo tag
  2. Click on name_1 label
  3. ...

I tried it again on the same computer just now having updated firefox to version 11 from version 10 (why do they have to update it so often?) and It seems to be working fine. Obviously nothing was wrong with FF after all :)

EDIT: Meant to say nothing was wrong with Potlatch, not firefox

comment:6 Changed 7 years ago by Richard

The TagGrid? tab/enter behaviour has been fixed up really recently (in the past three days) so I guess it's possible that you caught an un-updated version of Potlatch first time round.

Note: See TracTickets for help on using tickets.