Opened 7 years ago

Closed 7 years ago

#4367 closed defect (duplicate)

some tags are altered in the browse view

Reported by: dieterdreist Owned by: Dan Karran
Priority: major Milestone:
Component: website Version:
Keywords: altered tags Cc: Karl Ove Hufthammer

Description

E.g. if there is an object tagged like this:

<tag k="wikipedia" v="it:Provincia di Aosta"/>

the tags on the browse page http://www.openstreetmap.org/browse/relation/45154 will show the tag like this:

wikipedia = Provincia di Aosta

As this view is mainly intended for mappers it would be better to show them all tags in unaltered form without any "beautifying".

Change History (5)

comment:1 Changed 7 years ago by Tom Hughes

Owner: changed from rails-dev@… to Dan Karran
Status: newassigned

comment:2 Changed 7 years ago by Karl Ove Hufthammer

Cc: Karl Ove Hufthammer added

I agree. I found the current behaviour very confusing. For example, the changeset changing version 2 to 3 at http://www.openstreetmap.org/browse/node/1426281643/history lead me to think the person had *broken* the wikipedia tag, not fixing it.

comment:3 Changed 7 years ago by dankarran

I agree too, the language code should be left next to the title instead of stripping it.

comment:4 Changed 7 years ago by ppawel@…

Unless you have other examples of tags that are modified for display, this looks like a duplicate of #4315 which has been fixed recently.

comment:5 Changed 7 years ago by Tom Hughes

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.