Opened 7 years ago

Closed 7 years ago

#4371 closed defect (duplicate)

Potlatch2 doesn't show a relation that you've just created in the "add to" list

Reported by: SomeoneElse Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: relations Cc:

Description

I'm just in the process of making way 56384577 into the outer part of a multipolygon. I've added the relation, and (eventually) managed to get it so that way 56384577 shows the relation as "role outer" in the relation list. The ID displays as +44/0.

The inner ways already exist as ways (e.g. way 160493065). If I click on that and then "add to" I see a list of relations, but not the relation that I have just created but not yet saved.

Change History (3)

comment:1 Changed 7 years ago by stevage

Keywords: relations added
Type: enhancementdefect

What you're describing would be a bug. I can't reproduce this the way I understand it.

  1. Start with ways A and B
  2. With A selected, use "Add To" [relation] button to create multipolygon relation X (simple editor)
  3. Now, select B
  4. Press "Add To"
  5. X fails to display in list?

Works for me. I'm confused by your +44/0 though. It would have a negative number, like -1, no?

What are the exact steps to reproduce?

comment:2 Changed 7 years ago by SomeoneElse

What are the exact steps to reproduce?

They're on #4372 , which I logged once I realised it was a bit more of a widespread problem.

comment:3 Changed 7 years ago by stevage

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.