Opened 12 years ago

Closed 12 years ago

#440 closed defect (fixed)

Sending a message doesn't work

Reported by: Bruce Cowan Owned by: Tom Hughes
Priority: major Milestone:
Component: rails_port Version:
Keywords: Cc: Dan Karran, brwk@…

Description

Sending a message fails, error message is as follows:

Application error

Change this error message for exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code) in public/500.html

Change History (6)

comment:1 Changed 12 years ago by nickblack1@…

Owner: changed from steve@… to nickblack1@…
Status: newassigned

comment:2 Changed 12 years ago by Tom Hughes

Cc: Tom Hughes added

The problem is that app/controllers/message_controller.rb is not setting message.user_id and the database requires that column to be non-null so we get an error when inserting the message.

I'm not sure what the user_id field in the messages table is for anyway? It already has from_user_id and to_user_id to indicate sender and recipient?

comment:3 Changed 12 years ago by Dan Karran

Cc: Dan Karran added

Curious as to why this works on my local install but not the server version?

comment:4 Changed 12 years ago by Tom Hughes

Cc: Tom Hughes removed
Owner: changed from nickblack1@… to Tom Hughes
Status: assignednew

This will be fixed as part of the database schema update I am working on, which will remove the problem column from the messages tables.

comment:5 Changed 12 years ago by brwk@…

Cc: brwk@… added

comment:6 Changed 12 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

This is now fixed.

Note: See TracTickets for help on using tickets.