Opened 7 years ago

Closed 5 years ago

#4436 closed defect (fixed)

mod_tile compilation error (problem with image_32 buf on line 445 of gen_tile.cpp)

Reported by: test1000@… Owned by: tile-serving@…
Priority: blocker Milestone:
Component: mod_tile Version:
Keywords: Cc:

Description

Hello,

I've encoutered some problems compiling mod_tile, with the command "make".
Indeed, when the compiler is focusing on gen_tile.cpp, the console gives me those errors :

g++ -DHAVE_CONFIG_H -I.  -I/usr/include/freetype2 -pthread -I/usr/include -D_REENTRANT  -I/usr/local/include    -g -O2 -MT gen_tile.o -MD -MP -MF .deps/gen_tile.Tpo -c -o gen_tile.o gen_tile.cpp
In file included from gen_tile.cpp:5:
/usr/local/include/mapnik/filter_factory.hpp:1:2: warning: #warning "filter_factory.hpp" is now called "expression.hpp"
gen_tile.cpp: In function ‘protoCmd render(mapnik::Map&, char*, mapnik::projection&, int, int, int, unsigned int, metaTile&)’:
gen_tile.cpp:445: error: variable ‘mapnik::image_32 buf’ has initializer but incomplete type
gen_tile.cpp:453: error: ‘image_view’ was not declared in this scope
gen_tile.cpp:453: error: expected primary-expression before ‘>’ token
gen_tile.cpp:453: error: ‘vw’ was not declared in this scope
make[2]: *** [gen_tile.o] Error 1
make[2]: Leaving directory `/home/direst/osm/mod_tile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/direst/osm/mod_tile'
make: *** [all] Error 2

Apparently, I can't instantiante the value buf and can't understand why.
My OS is Debian 6 Squeeze and I've installed Mapnik properly, according to this following site :
[https://github.com/mapnik/mapnik/wiki/Mapnik2 ]
The libboost version I have is 1.49 and I've also the latest ICU version.
In order to install mod_tile, I've performed those operations :

cd ~/osm/
svn co http://svn.openstreetmap.org/applications/utils/mod_tile
cd mod_tile
./autogen.sh
./configure
make
sudo make install
sudo make install-mod_tile


But the "make" and "sudo make install" commands are not the working. "sudo make install-mod_tile" is working actually.
If I can't compile, I will not be able to perform this commande : " ./renderd -f"

So if anyone has a solution...

Thanks

Change History (4)

comment:1 Changed 7 years ago by johannes.brandstetter@…

Same error here on CentOS 6.2, icu 49, mapnik 2.0.1-pre

comment:2 Changed 7 years ago by johannes.brandstetter@…

Update:

adding #include <mapnik/graphics.hpp>

to gen_title.cpp fixed it

comment:3 Changed 6 years ago by Tom Hughes

Component: mapnikmod_tile
Owner: changed from mapnik-team@… to tile-serving@…

comment:4 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The source for mod_tile is now at https://github.com/openstreetmap/mod_tile. As this is a 17 month old report and there are no current indications this is an issue, I'm going to close this.

Note: See TracTickets for help on using tickets.