Opened 7 years ago

Closed 7 years ago

#4469 closed defect (duplicate)

Nominatim won't search some Korean text?

Reported by: gs25 Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

Here is Toyoko Inn in Seoul. There are many of these hotels in Korea and Japan.

http://www.openstreetmap.org/browse/node/871717853

Nominatim search for "Toyoko Inn, Seoul" is great! "Toyoko Inn, Busan" or "Toyoko Inn, Tokyo" works as expected too.

"東横イン", which is Japanese for "Toyoko Inn", seems to work. I get some useful results. "토요코인", which is Korean for "Toyoko Inn", does not work. I get no results, but I know this string is in the name=* field.

Please tell me if this is a bug, or if there is a problem with the data. If it's a bug, please mark it as a 'to do'. If it's a problem with the data, please explain how to do it properly and I will re-do all Toyoko Inn hotels in Korea (there are about 8 of them).

I have had success searching for other Korean text. For example, "중앙로" or "Jungang-ro", which means "Central Street", will give some results.

Thank you.

Change History (2)

comment:1 Changed 7 years ago by datendelphin

This is a bug in nominatim. Searching for one word of the korean name string doesn't work. But Searching for the whole string works.

comment:2 Changed 7 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

Partial searches only work for a single word at the moment. 토요코인 is considered as three words for sake of transliteration, which is why it is not found.

Marking this one as a duplicate of #2485 (better support of partial words).

Note: See TracTickets for help on using tickets.