Opened 7 years ago

Closed 18 months ago

#4476 closed defect (fixed)

mod_tile vs. httpd-2.4

Reported by: mjoost Owned by: jburgess777@…
Priority: blocker Milestone:
Component: mod_tile Version:
Keywords: mod_tile, httpd-2.4 Cc:

Description

Due to API-changes and compile-option changes inside Apache's actual httpd-2.4.2 version the mod_tile package fails to compile.

Attached is a patch that fixed those problems for me on mod_tile rev 28468.

The patch imposes a hard dependency on httpd-2.4, i.e. won't compile with previous httpd-2.2. Perhaps a few additional #ifdefs on httpd minor version regarding the API changes might be useful.

Attachments (1)

mod_tile_apache2.4.patch (18.8 KB) - added by mjoost 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by mjoost

Attachment: mod_tile_apache2.4.patch added

comment:1 Changed 6 years ago by amm

I have just committed some changes that make mod_tile compile on Apache 2.4 ( as well as Apache 2.2 )

This does not include the changes for C90 compliance, as that was not necessary for me to get it to compile. Do you still need those? On what platform are you compiling this?

Sorry for the long delay to getting to this issue.

comment:2 Changed 6 years ago by amm

Turns out C90 compliance is necessary if Apache is built with --enable-debugger-mode. So I have now committed changes to make this the case.

Can you close the bug report if you are satisfied with the outcome?

comment:3 Changed 6 years ago by mjoost

Sorry, haven't followed here after the issue being dead for such a long time.

I was not aware that the C90 issue is dependent on that debugging option, but yes, my Apache had been built with that option set.

I won't be able to verify your commits for some time, but have no objections on closing this ticket if the problem is resolved for other users.

comment:4 Changed 18 months ago by pnorman

Resolution: fixed
Status: newclosed

Closing per comments in issue

Note: See TracTickets for help on using tickets.