Opened 7 years ago

Closed 7 years ago

#4485 closed defect (fixed)

Zoom level 17 getting bypass in map imagery when clicking "+" or "-" buttons to zoom.

Reported by: rickmastfan67 Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

Just happened to notice this weird bug that effects the level 17 zoom where in certain scenarios, you can bypass that zoom level completely.

Steps to reproduce:

  1. Load the following area (doesn't really matter where to be honest): http://www.openstreetmap.org/?lat=28.53826&lon=-81.34297&zoom=16&layers=Q
  2. Click the "+" to zoom in with your mouse.
  3. Notice that it jumps directly to zoom 18 bypassing zoom 17 completely.

This doesn't happen when you use the mouse's middle wheel to zoom in.

I've also been able to duplicate this in both IE-9 and FF14(beta) without fail.

Change History (2)

comment:1 Changed 7 years ago by woodpeck

This is due to a change in behaviour of the new OpenLayers? version. There is already a pending pull request from lonvia to fix this:

https://github.com/openstreetmap/openstreetmap-website/pull/53

comment:2 Changed 7 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

I've merged that fix now, and it will deploy shortly.

Note: See TracTickets for help on using tickets.