Opened 12 years ago

Closed 10 years ago

#449 closed defect (fixed)

Problems with VERY long ways

Reported by: frederik@… Owned by: frederik@…
Priority: minor Milestone:
Component: api Version:
Keywords: Cc:

Description

Current API chokes on extremely long ways. We have abotu 350 ways with more than 500 segments, 3 of them with more than 5000 segments.

As a quick remedy, I (Frederik) will split all these ways into pieces of max. 500 segments.

For the long term, we should either find a way to handle such ways gracefully OR disallow ways of more than 500 ways being created (just return an error message if someone tries).

Change History (2)

comment:1 Changed 12 years ago by frederik@…

Component: adminapi
Owner: changed from steve@… to frederik@…
Priority: majorminor

Problem has been mediated by splitting very long ways. Some cleanup still being done. Among the ~250 ways affected there are also 19 "natural=water" ways, presumably lakes; splitting may be reverted for those pending discussion on mailing list. Priority of this ticket downgraded to minor as the problem is only quick-fixed, not really solved.

John Burgess has made suggestions for possible long-term solutions in http://lists.openstreetmap.org/pipermail/dev/2007-May/004764.html.

comment:2 Changed 10 years ago by Thomas Wood

Resolution: fixed
Status: newclosed

Now limiting at 2000 nodes.

Note: See TracTickets for help on using tickets.