Opened 7 years ago

Closed 7 years ago

#4504 closed defect (duplicate)

Suburb should be shown only if the element is inside the city of which the suburb belong

Reported by: AnyFile Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

If I made a search for Via Archimede, Bresso, Italia

In the response I get ( place_id="37659795" osm_type="way" osm_id="27393925")

as well as <city>Bresso</city> I also get <suburb>Niguarda</suburb>

Now the suburb Niguarda (place_id=10578283 osm_node=957188590), is a suburb of the city Milano, not of the city Bresso.

Now it is clear from the documentation of suburb the a suburb is: "[...] a major sub-division of a place=town or place=city"

So I should assume that a suburb should not extend outside the city.

In this case the suburb is just a point and there is no a relation with is boundary, so it is not clear where the suburb ends, but surely it should not extend beyond the boundary of the city.

Looking from a different prospective (this may be easier to understand and implement), a suburb should be attached to an element only if the corresponding city or town is attached.

Change History (1)

comment:1 Changed 7 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

This has already been addressed in the latest version of Nominatim. Nodes are excluded from the address if they are outside the area of the next higher level. This newer version will go live on osm.org in a few weeks.

Duplicate of #4247.

Note: See TracTickets for help on using tickets.