Opened 7 years ago

Closed 7 years ago

#4535 closed defect (fixed)

Potlatch 2 Map Comes Up Blank on Mac

Reported by: warling Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version: 2.0
Keywords: mac, flash, blank Cc: warling

Description

With Flash 11.3.300.271 the Potlatch 2 editor comes up blank at all zoom levels. The menu displays correctly along the left-hand side. This is true of all web browsers (Firefox, Nightly, Chrome, Chromium, WebKit?). No ad blocking software is installed.

Attachments (1)

screenshot.png (56.9 KB) - added by warling 7 years ago.
screen shot

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by warling

Attachment: screenshot.png added

screen shot

comment:1 Changed 7 years ago by Richard

Just installed 11.3.300.271 on my Mac and it works fine for me (tested in Safari 5.1.6 and Opera 11.5).

You could try installing the Debug Player and seeing if it pops up any exceptions.

comment:2 Changed 7 years ago by warling

Cc: warling added

I've downloaded the latest and greatest version of Flash (11.4.x) along with the Flash Debug Player. The map still doesn't display in this version of Flash on my machine, but the Debug Player does spit out the following error:

Error: Error #2130: Unable to flush SharedObject?.

at Error$/throwError() at flash.net::SharedObject?/flush() at net.systemeD.potlatch2.collections::Stylesheets/setStylesheet() at net.systemeD.potlatch2.collections::Stylesheets/onStylesheetsLoad() at MethodInfo?-3653() at net.systemeD.halcyon::FileBank?/addFromFile() at net.systemeD.potlatch2.collections::Stylesheets/init() at potlatch2/startApp()

comment:3 Changed 7 years ago by Richard

Ah. You've probably got local storage disabled in your Flash Player (aka "Flash cookies"). P2 is trying to remember your settings from last time - selected background etc. - and complaining because it can't get at them.

If you open Apple menu -> System Preferences -> Flash Player -> Storage, you should see a three-position radio box. I'm guessing "Block all sites from storing information on this computer" is selected. Change this and retry.

If this fixes it I'll have a look at putting a try... catch block around the various pieces of SharedObject? code so that this doesn't cause P2 to bomb out.

comment:4 Changed 7 years ago by warling

Bingo! That was indeed the issue. I changed it to "Ask me before..." and now it works fine with the following exception, which I get twice while loading:

Error #2044: Unhandled NetStatusEvent:. level=error, code=SharedObject.Flush.Failed

(For what it's worth, I'd prefer to leave the setting at "Block all sites..." because, well, you know...paranoia :-)

Thanks for your help! I'll leave you to close out the bug once you've made the necessary changes.

comment:5 Changed 7 years ago by Richard

Resolution: fixed
Status: newclosed

Fix committed in https://github.com/systemed/potlatch2/commit/f5ffc13d7b06c68e81f10c80dafd81977f3c05ce . But you should let openstreetmap.org store SharedObjects? anyway ;)

Note: See TracTickets for help on using tickets.