Opened 7 years ago

Last modified 7 years ago

#4536 new defect

OCM: highway segments not rendered due to incompletely described relation

Reported by: velotopist Owned by: Andy Allan
Priority: minor Milestone:
Component: opencyclemap Version:
Keywords: highway rendering Cc: velotopist

Description

I observed that some highways are not properly rendered in OCM when they are part of an incompletely described relation (gaps, Y-connections). An example is relation 901203 (german cycle route D3).

It seems that some nodes of the relation (in correctly described areas) are connected like a "zigzag" pattern to nodes at interruptions some hundreds meters or kilometers far away (the bad order of the nodes can be seen in a gpx download of the relation).

This prevents highways from being correctly rendered and it causes interruptions in the color line representing the relation - far away from the real relation problem (compare attached OCM and OSM screenshots).

Attachments (3)

D3-Gaps_OCM.jpg (200.4 KB) - added by velotopist 7 years ago.
D3-Gaps_OSM.jpg (146.4 KB) - added by velotopist 7 years ago.
D3.gpx (98.9 KB) - added by velotopist 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by velotopist

Attachment: D3-Gaps_OCM.jpg added

Changed 7 years ago by velotopist

Attachment: D3-Gaps_OSM.jpg added

Changed 7 years ago by velotopist

Attachment: D3.gpx added

comment:1 Changed 7 years ago by velotopist

The errors in the 901203 relation were repaired in the last days, so the effect will disappear in the near future.

comment:2 Changed 7 years ago by velotopist

Cc: velotopist added
Keywords: highway rendering added
Note: See TracTickets for help on using tickets.