Opened 7 years ago

Closed 6 years ago

#4540 closed defect (fixed)

weird "read-only" symptom on my OSM account

Reported by: cquest Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc: FrViPofm

Description

Since yesterday night, I was not able to upload data to OSM. JOSM is stuck in on the "opening a new changeset" message. I tried Potlatch... same problem.

I tried on different machines/OS (OSX/Ubuntu), same problem.

I have no problem logging on osm.org, but when I want to change anything on my option page, like my password, my location on the map or my prefered editor... I never get any answer and the browser is stuck (I tried different ones too).

It look like my "cquest" account became "read-only"... because if I use another account (cq_bot) no problem at all !

The above tests came from talks on irc #osm channel...

Any idea ?

Christian Quest - cquest@…

Change History (9)

comment:1 Changed 7 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

Your account looks completely normal to me, and we have no such concept as a "read-only" account.

comment:2 in reply to:  1 Changed 7 years ago by cquest

Resolution: invalid
Status: closedreopened

Replying to TomH:

Your account looks completely normal to me, and we have no such concept as a "read-only" account.

Yes it looks normal, but it is not.

Can you try sending me a private message on it ?

Do you want my password to test yourself ?

By the way, another user just send me a direct email saying he was having the same problems... (http://www.openstreetmap.org/user/bmarand)

I'll stay on IRC #osm just in case...

comment:3 Changed 7 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

It turned out that you had an upload that was wedged and was holding a lock on your user record. I've killed it now so things should be working again.

comment:4 in reply to:  3 Changed 7 years ago by cquest

Replying to TomH:

It turned out that you had an upload that was wedged and was holding a lock on your user record. I've killed it now so things should be working again.

Thanks ! I confirm that everything is back to normal on my side.

comment:5 Changed 6 years ago by FrViPofm

Resolution: fixed
Status: closedreopened

It seems I have the same problem :

(posted on talk) Hi all, I've made few changes near [1]

I have made changes with JOSM yesterday. I was unable to upload them. So I have saved the file. I have tried also yesterday to make some changes with Potlatch2 in the same hamlet. Potlatch could not create a changeset.

Today, I have tried to upload my changes from yesterday with JOSM. But JOSM can't create a changeset. So I canceled the upload. I have tried again to make some changes with Potlatch. Few changes were accepted in the changeset 15685756 : modifying the name of a church, adding a hamlet. So I tried to upload my JOSM's changes. And I have stille the same problem : JOSM stops on the stage "creating a changeset..." (into French)... And again I tried to make some changes with Potlatch2 (adding a point cemetary). Now Potlatch is still trying : "Saving to changset 15685756".

Is it a problem linked to my account ? Is it a known issue ?

Some infos : OSM account : FrViPofm? IP : 86.218.199.87 (probably other yersterday) I have updated JOSM latest yersterday : my version is 5837

Both JOSM and Potlatch are still trying to create the changeset or upload changes.

[1] http://osm.org/go/xVefgMCmp--

comment:6 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

I think your account should be unlocked now.

comment:7 Changed 6 years ago by FrViPofm

Cc: FrViPofm added
Resolution: fixed
Status: closedreopened

Sorry to reopen... My account is still in read only : Unable to upload with JOSM. Unable tou create a changeset with Potlatch. Unable to save chages in my account.

comment:8 Changed 6 years ago by FrViPofm

OK,

This morning I have made some changes with Potlatch and savec them [1]. OK

I have opend JOSM, made few changes and saved them [2]. OK

I have opend my file "data2upload.osm" [3] and tried to upload it. Failed.

I have tried to make a new change with Potlacht and save it. Failed.

[1] http://www.openstreetmap.org/browse/changeset/15709362

[2] http://www.openstreetmap.org/browse/changeset/15709375

[3] http://frvipofm.net/osm/data/data2upload.osm

comment:9 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

I think the problem is most likely just that the data you uploaded from data2upload.osm is large, and touches a number of very large and complicated relations, so processing it will take some time and your user record is likely to be locked during that processing.

You should really wait for a changeset upload to complete before trying to do any more edits, or at least before trying to do any more uploads.

In any case this is not related (and never really was) to this ticket, so we should stop reopening this ticket now.

Note: See TracTickets for help on using tickets.