Opened 7 years ago

Closed 7 years ago

#4541 closed defect (fixed)

Nominatim Internal Server Error on bounded=1

Reported by: CycleStreets Owned by: Sarah Hoffmann
Priority: major Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

This query generates an Internal Server Error:

http://nominatim.openstreetmap.org/search?q=x&bounded=1

whereas the same query but with bounded=0 does produce results.

I first found this problem with this query:

http://nominatim.openstreetmap.org/search?format=json&addressdetails=1&limit=10&q=lower+s&viewbox=-11,61,2,48&countrycodes=gb,ie&bounded=1

Change History (3)

comment:1 Changed 7 years ago by CycleStreets

Note: the internal server error does not occur if results are more likely, such as this search for station road.

comment:2 Changed 7 years ago by Sarah Hoffmann

Owner: changed from geocoding@… to Sarah Hoffmann
Status: newaccepted

Incidentally, you've hit two different bugs here.

The first query actually does not really make sense, one shouldn't ask for bounded results without supplying a viewbox, that confused the server. The original problem is something different, it was caused by a change in the internal table layout.

Quick-fixed both problems on the server. I shall properly check in the fix into the main repo later.

comment:3 Changed 7 years ago by Sarah Hoffmann

Resolution: fixed
Status: acceptedclosed

Properly fixed now.

Note: See TracTickets for help on using tickets.