Opened 5 years ago

Closed 4 years ago

#4551 closed defect (fixed)

Zoom scale is too big

Reported by: Evropi Owned by: rails-dev@…
Priority: trivial Milestone:
Component: website Version:
Keywords: zoom, unzoom Cc:

Description

The last two parts of the scale to unzoom are not actually used on OpenStreetMap. If you click the minus symbol, the map will not unzoom further. I suggest removing them.

Now, I'd assume this is because you have not adapted OpenLayers? or whatever you are using now appropriately to OSM. I'd assume adapting the scale so every part of it actually zooms the map in and out shouldn't be too difficult.

Change History (6)

comment:1 Changed 5 years ago by TomH

You seem to have things back to front - the problem is that the new zoom control doesn't seem to allow zoom levels 1 and 2 to be selected anymore. They are however intended to work as they always have before.

comment:2 Changed 5 years ago by tmcw

No and no: the zoom control allows you to zoom to the minimum extent of the map, not necessarily the minimum zoom. Try it yourself - on a huge screen, the minimum zoom allows is higher than on a smaller screen. Since the zoom control disappears on tiny screens that would allow one 256x256px tile to be the maximum extent, z0 is rarely functional on the panzoombar.

Please don't write that work or thought hasn't been invested, and especially not that various things 'shouldn't be too difficult'. Focus on issues themselves.

comment:3 Changed 5 years ago by TomH

Well something has changed - you used to be always be able to zoom out to z0 and you would just get "coming soon" tiles about and below the map.

I don't if the change is down to the new panzoom control, or maybe is change in behaviour in OL 2.12 instead?

It sounds like you're saying it is deliberate though, that you can't zoom out beyond the point where the map wouldn't fill the frame?

comment:4 Changed 5 years ago by TomH

Checking my http://maps.compton.nu/ site, which is using the traditional OL panzoom control, it seems to be doing the same thing so my guess is that this is an OL 2.12 change.

comment:5 Changed 5 years ago by Evropi

  • Priority changed from minor to trivial

I'm on a 1280*1024 resolution screen. On TomH's website, I can't go to the last three zoom levels. On openstreetmap.org, I can't go to zoom levels 0 and 1.

Basically I just want the scale to be accurate. I admit the previous system where you'd get enormous grey borders around the map was not too pretty, but it doesn't tease you with the last 2 zoom levels!

Oh well, it's not that big of an issue (hence the minor priority, which just became trivial). And as it sounds, OSM can't do anything about this, only the OpenLayers? man can. Never you mind. You can close this if you want or leave it for the backlog.

comment:6 Changed 4 years ago by aseerel4c26

  • Resolution set to fixed
  • Status changed from new to closed

The map on www.osm.org is not anymore OpenLayers? (but leaflet) if I see correctly - since some months. And furthermore the zoom scale was removed completely (sadly).

Note: See TracTickets for help on using tickets.