Opened 7 years ago

Closed 7 years ago

#4555 closed defect (invalid)

Long list of roads/buildings/features appearing under the "parentage" of a suburb rather than the town

Reported by: djfisher81@… Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

Pretty much the entirety of central Croydon (Greater London, UK) is listed as being within "Thornton Heath" and also "SE25". Croydon is a large town; Thornton Heath is a suburb lying to the north, and SE25 is the postal code of South Norwood, a different suburb lying to the north-east. Looking at the Nominatim results for Thornton Heath (http://nominatim.openstreetmap.org/details.php?place_id=4358752) and Croydon (http://nominatim.openstreetmap.org/details.php?place_id=113996), the only possible problem I can see is that Croydon is listed as "Rank: Village/Hamlet?" but I'm not sure what this means in practice, especially as it also has "Admin Level: 15" which is (I think?) correct...

As a specific instance, Surrey Street (http://nominatim.openstreetmap.org/details.php?place_id=37838695) is a street in central Croydon which has the misattribution described above.

Change History (2)

comment:1 Changed 7 years ago by Shaun McDonald

The problem is that nodes are used. An area needs to be added, and the node removed to get accurate results. The latest Nominatim has a new feature to be able to link a node and area together and use the area instead of the inaccurate point.

comment:2 Changed 7 years ago by Sarah Hoffmann

Resolution: invalid
Status: newclosed

As smsm1 explained this is a data problem.

However, once you have added the area/boundary, don't delete the node but instead add it to the boundary relation with the role 'label', so that Nominatim knows they belong together. The place nodes are really useful to know where the centre of the suburb is.

Note: See TracTickets for help on using tickets.