Opened 7 years ago

Closed 7 years ago

#4575 closed defect (duplicate)

Wrong province(state) in address even after is_in tag is specified

Reported by: namuori Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

After fixing the issue that was ticket #4557, I'm now noticing that Nominatim is picking the wrong, adjacent province for the addresses for many of the cities in Gyeonggi-do (Gyeonggi Province). Here are a few examples.

Dongducheon: http://nominatim.openstreetmap.org/details.php?place_id=3977812

This city is well within Gyeonggi-do's border, yet it's being listed under Gangwon-do.

Paju: http://nominatim.openstreetmap.org/details.php?place_id=2688795

This one simply doesn't have any province assigned to it.

Anseong: http://nominatim.openstreetmap.org/details.php?place_id=3226407

This one shows up to be under Chungcheongbuk-do.

What's interesting to note is that these nodes are linked to admin borders, and these properly list them under Gyeonggi-do: http://nominatim.openstreetmap.org/details.php?place_id=2486970788 http://nominatim.openstreetmap.org/details.php?place_id=2486970801 http://nominatim.openstreetmap.org/details.php?place_id=2486970785

I'm suspecting that Gyeonggi-do node... http://nominatim.openstreetmap.org/details.php?place_id=2487216741

...is somehow not properly assigned to the cities. I've even explicitly put is_in tags in the city nodes as FAQ suggested, but it didn't do any good.

Change History (1)

comment:1 Changed 7 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

This is caused by bug #4550, already fixed in code. It will be deployed with the next reimport in a few weeks.

NB: those cities appear in the county relation with role 'label'. This sounds like it is incorrect. I presume that the county and the city are not the same but that the city is the administrative centre of the county. In that case the role should be 'admin_centre'. (Incidentally, changing this will also work around this bug.)

Note: See TracTickets for help on using tickets.