Opened 7 years ago

Closed 7 years ago

#4587 closed defect (fixed)

"edit?gpx" links from the GPS trace list seem to edit at last map view location, not trace location

Reported by: SomeoneElse Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

Example to reproduce:

o Set preferred editor to Potlatch 1 (may not be necessary, but that's how mine's set)

o Browse the map somewhere

o Click "edit" on a trace in the trace list - URL is something like http://www.openstreetmap.org/edit?gpx=1220134

o Note that editor window opens at last browse location not trace location.

Note that edit from "view trace" ("more" in GPS trace list) works fine - URL is something like http://www.openstreetmap.org/edit?gpx=1220134&lat=53.1303&lon=-1.12974&zoom=14

Change History (3)

comment:1 Changed 7 years ago by Tom Hughes

I suspect this is specific to Potlatch 1 actually - there was a change the other day that will have caused it and thinking about it there was change made to the Potlatch 2 partial that needs to be made for Potlatch 1 as well.

comment:2 Changed 7 years ago by jfire

Tom, I can take this, since it was my change. While we're at it, I'll add support for the node and way params to Potlatch 1 as well.

comment:3 Changed 7 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

I've merged John's fix for this and it will deploy shortly.

Note: See TracTickets for help on using tickets.