Opened 7 years ago

Closed 7 years ago

#4598 closed defect (invalid)

Apostrophes in XML output should be replaced with ' entities

Reported by: Zverik Owned by: rails-dev@…
Priority: major Milestone:
Component: api Version:
Keywords: apos, xml Cc:

Description

In all of API responses, planet dumps and replication diffs. Using ' symbol in XML is allowed, but is considered a bad practice, and can cause some parsers to miss parts of tag parameter values.

Change History (2)

comment:2 Changed 7 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

This is not a bug - when an attribute value is in double quotes a single quote does not need to be escaped and vice versa.

Note: See TracTickets for help on using tickets.