Opened 7 years ago

Closed 7 years ago

#4618 closed defect (fixed)

Long period of unresponsiveness after selecting ways with bus route relations

Reported by: gbee Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

Linux (Mageia 2) Opera 12.02 Flash 11.2.202.238

If I select any route of any size, which has a bus route relation then nothing happens, Potlach stops responding to input and Opera eventually decides that flash has crashed, in fact it just appears to be unresponsive for at least two minutes. I can select and edit any other node or way without issue.

Only in the last week has this issue manifested when editing from the openstreetmap.org site. I can be reasonably precise about the timing as I spent the week before this adding and editing bus route relations along ways in the city of Derby, UK.

It seems to be browser independent (Firefox, Konqueror, Webkit all tested) and the version of flash being used hasn't changed that I'm aware of. I tried the last point release of flash (11.2.202.235) with the same results.

I've tried deleting all local flash storage and configs to no avail.

Change History (7)

comment:1 Changed 7 years ago by Richard

Hm. Curious - it works fine for me (OS X with Flash 11.3). Anyone else able to confirm or otherwise?

comment:2 Changed 7 years ago by gbee

I've since discovered it also applies to cycle route relations and footpath relations (e.g. Derwent Valley Heritage Trail) - the type of way doesn't seem to matter, footpath/cycle path/track/service road/residential road/tertiary etc.

Now running flash 11.2.202.243, the *latest available release for linux.

Are there any older versions of Potlach 2 in use somewhere that I could try against? May help to narrow down the version in which this problem was introduced?

*(Since Adobe decided they would gradually kill off flash in favour of HTML 5, they are now only providing security updates and not new feature releases on some platforms)

comment:3 Changed 7 years ago by gbee

Another potentially useful data point. I'm able to successfully select the way using Ctrl+Click, or ctrl+click & drag to include part of the way without it locking up/freezing.

comment:4 Changed 7 years ago by Richard

It sounds like the issue is related to rendering the editor panel (on the left-hand side). Still peculiar that it's showing up on your system and not elsewhere, though. Any other Linux users able to confirm or otherwise?

comment:5 Changed 7 years ago by gbee

I don't know that it's directly related, but if I do manage to select a way with a bus route relation then the new direction information shown in the simple panel is wrong anyway (show correctly in the advanced panel). It always shows the direction as 'forwards' even for routes which are 'backwards' or bi-directional. If I select the direction drop-down and try to change it then again it freezes up.

comment:6 Changed 7 years ago by gbee

The original issue and the one mentioned in my last comment now seem to be fixed.

comment:7 Changed 7 years ago by Richard

Resolution: fixed
Status: newclosed

Interesting. Maybe related to the Flash Player for Linux bug identified (and fixed) in https://github.com/systemed/potlatch2/commit/ef38cd3ce82b6768a9f3bbe30f88eed9c9d39443 .

Note: See TracTickets for help on using tickets.