Opened 7 years ago

Closed 5 years ago

#4645 closed defect (fixed)

Don't render political boundary names

Reported by: tom@… Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

I recently added a bunch of relations for political boundaries (wards and Parliamentary constituencies) in the London Borough of Southwark. The names for these are now being rendered on the map, which I think is confusing:

http://www.openstreetmap.org/?lat=51.4658&lon=-0.0678&zoom=14&layers=M

These aren't commonly used names, they are positioned in odd places due to the oddities of political boundaries, and they often duplicate actual place names (for example Peckham towards the centre top of the above map and East Dulwich towards the centre bottom).

They shouldn't be rendered at all, they are useful for specialist maps but not the main osm.org map.

The tagging on the relations is: boundary = political political_division = ward OR parl_const

Change History (1)

comment:1 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The catch-alls that were the cause of many of these names have been removed.

Note: See TracTickets for help on using tickets.