Opened 7 years ago

Closed 5 years ago

#4670 closed defect (fixed)

RSS auto discovery link missing from diary entry lists

Reported by: Zverik Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: rss, diary Cc:

Description

All those pages have no link to their RSS feeds. But they had some time ago. Probably a regression, and needs to be fixed.

Change History (10)

comment:1 Changed 7 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

They all seem to have RSS links when I look at them.

comment:2 Changed 7 years ago by Shaun McDonald

It's the orange RSS icon at the bottom of the page on all three of those pages.

comment:3 Changed 7 years ago by Zverik

Ok, I agree that there are RSS links at the bottom. But all RSS readers and browsers expect them to be in meta tag:

<link rel="alternate" type="application/rss+xml" title="RSS" href="http://openstreetmap.org/diary/rss" />

So I propose to add this tag where relevant.

comment:4 Changed 7 years ago by Zverik

Resolution: invalid
Status: closedreopened

comment:5 Changed 7 years ago by Tom Hughes

We do add it - that's what the auto_discovery_link_tag line in app/views/diary_entry/list.html.erb does.

I think it's being defeated by the caching on the page though, and there's no real way to fix that without reworking the caching completely. It works on my dev instance where there is no caching.

Firefox at least long since stopped paying any attention to those tags anyway.

comment:6 Changed 7 years ago by Tom Hughes

Summary: No link to RSS in user diariesRSS auto discovery link missing from diary entry lists

comment:7 Changed 7 years ago by Zverik

I've checked http://www.openstreetmap.org/diary/fr which I've never visited in my life, and there is no RSS auto discovery link. Should it appear after anyone adds another diary entry, or the caching is more complicated than that?

comment:8 Changed 7 years ago by Tom Hughes

No the point is that if the page is cached (this is a server side cache) then the view is never run and hence the content_for block doesn't stash the content so when :head is rendered the auto_discovery_link_tag is not there.

Basically the cache only stores the actual content of the page and not the side effects like content_for blocks.

comment:9 Changed 7 years ago by Zverik

Is it possible to clear relevant caches when restarting the server, if this would come up anytime soon? Right now it seems like we cannot modify website's pages at all because of caching. Not that it is needed often.

comment:10 Changed 5 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

The caching of this page was removed some time ago, which fixed this.

Note: See TracTickets for help on using tickets.