Opened 7 years ago

Closed 5 years ago

#4685 closed enhancement (duplicate)

public_transport=platform does not get rendered

Reported by: teddych Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: public_transport platform Cc:

Description

118'000 objects have already been added to the OSM database with public_transport=platform.

I would expect public_transport=platform to be rendered like railway=platform and/or highway=platform. Actually it does not get rendered at all.

Change History (6)

comment:1 Changed 7 years ago by Ldp

public_transport=* rendering will become possible after the next full import of the database.

The public_transport key is currently not yet available in the rendering database.

comment:2 Changed 6 years ago by Polyglot

When will this next import occur?

comment:3 Changed 6 years ago by Seoman

see ticket #4381, too

Last edited 6 years ago by Seoman (previous) (diff)

comment:4 Changed 6 years ago by Polyglot

I tried to add another bus stop, omitting highway=bus_stop.

This time I added bus=yes in addition to public_transport=platform (That makes a difference in JOSM), but still no joy.

I'm about to add 35000 stops, so I'd like to get it right the first time, for most of them... rather than having to mass retag them once more in a month, a year or a decade.

comment:5 Changed 6 years ago by skyper

Please girls and guys.

This is still an issue and especially railway=platform is stange as there are no rails and I hope I will never find a train/tram at that place.

comment:6 Changed 5 years ago by pnorman

Resolution: duplicate
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The standard tag for a bus stop remains highway=bus_stop, and this is a duplicate of https://github.com/gravitystorm/openstreetmap-carto/issues/311

Note: See TracTickets for help on using tickets.