Opened 7 years ago

Closed 7 years ago

#4693 closed defect (fixed)

Nominatim using wrong relation for county outline

Reported by: blahedo Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc:

Description

Searches for Farmville, Virginia (spans Prince Edward and Cumberland counties) describe it as being in Appomattox County; viewing Appomattox County in the Nominatim database (3665338557) displays the same map as that of Prince Edward County (3665865857, which is correct), but it does correctly report Appomattox County as being represented by multipolygon relation 2534165, and clicking on the link to that relation shows the correct outline for Appomattox County. It doesn't appear to be bad data in the main OSM database (the relations and names are correct), so I guess it's a Nominatim bug of some sort.

Change History (1)

comment:1 Changed 7 years ago by Sarah Hoffmann

Resolution: fixed
Status: newclosed

The recent boundary cleanup in Virginia has caused a bit of confusion in Nominatim. The problem is that Nominatim does not update relations when a member way is changed and therefore ended up with the occasional mesh-up of old and new data. The counties above are now clean. Let me know if there are further problems.

Note: See TracTickets for help on using tickets.