Opened 7 years ago

Closed 7 years ago

#4698 closed defect (duplicate)

When addr:place is given, the object should not be automatically associated to a street

Reported by: ajank Owned by: geocoding@…
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc: ESYSCODER

Description

In many countries, small villages do not have street names, and the addresses are formed by combining the village name itself with a house number. According to OSM wiki, the "part of address, which is not related to street, but to some territorial zone, linear object, node or some abstract object" should be put under addr:place tag.

An example house, bearing the postal address "Pomocnia 4, 06-121 Pomocnia", is tagged as follows: addr:housenumber = 4 + addr:place = Pomocnia + addr:city = Pomocnia + addr:postcode = 06-121: http://nominatim.openstreetmap.org/details?osmtype=W&osmid=185887900.

Apparently Nominatim desperately tried to associate the object with any named street. In this case, the nearest one occurred to be a tertiary road in the neighbouring village, Piskornia Duża. Unfortunately there is no way of explicitly saying that there is no street name in the address (like addr:street = NULL).

In my opinion, if an object has the addr:place tag, Nominatim should refrain from automatically associating it to a nearest named street, and handle the value of addr:place like an abstract street name. Such a small change in the algorithm would be a huge improvement to address handling in rural areas worldwide.

Change History (2)

comment:1 Changed 7 years ago by ESYSCODER

Cc: ESYSCODER added

comment:2 Changed 7 years ago by Sarah Hoffmann

Resolution: duplicate
Status: newclosed

Duplicate of #3425

Note: See TracTickets for help on using tickets.