Opened 6 years ago

Closed 5 years ago

#4716 closed enhancement (wontfix)

[roads] Failure to render 4wd_only on the slippery map may well put lives at risk !

Reported by: Davo Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: slippery map Cc:

Description

Hi Folks, I would like to bring to your attention the fact that the slippery map on the main OSM website does not render the 4wd_only tag.

As this tag is applied to roads that can be dangerous to the unwary, this is quite a risky situation. Here, in Australia, we are lucky enough to have a large number of accessible 4wd roads and many show up on OSM.

Further, routing tools are starting to appear that many people allow to make decisions for them. Sadly. In the Aussie press at the moment are a number of potentially life threatening situations relating to people using Apple's mapping tools. You and I agree they are silly people but the press and the police just blame Apple. I don't want to see OSM in that position.

I have spoken to the developers of one of the better routing engines and their view is that a tag that does not make it to the OSM Reference Implementation, that is, the slippery map on the main web page, is not important enough to worry them. Oh dear !

When approved, the 4wd_only=yes tag was intended to be rendered by adding the text "(4wd Only)" to the road name. That would be a good model ! But note that since that tag was approved, the need for finer granularity has emerged and there has been a lot of use of the 4wd_only=recommended. It would be worth observing that too. (Indeed, planning for the future, 4wd_only=extreme might happen).

And please don't assume this relates to only roads declared highway=track. We have many roads that need to be primary or secondary (because of their purpose) but are 4wd only.

Note that this ticket has a lot of similarities to #1447, I added a comment there too.

Guys, lets be clear here, this is a dangerous situation !

David

Attachments (1)

sugarloaf_track_only.png (5.6 KB) - added by Davo 6 years ago.
showing a sample rendering of a 4wd_only road.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Davo

Attachment: sugarloaf_track_only.png added

showing a sample rendering of a 4wd_only road.

comment:1 Changed 6 years ago by Tom Hughes

Perhaps you should explain to people that the map on the front page is not, and never has been, a "reference implementation" of anything.

comment:2 Changed 5 years ago by math1985

Summary: Failure to render 4wd_only on the slippery map may well put lives at risk ![roads] Failure to render 4wd_only on the slippery map may well put lives at risk !

comment:3 Changed 5 years ago by math1985

Resolution: wontfix
Status: newclosed

I think rendering 4wd only might even put more lives at risk, because it assumes that all other roads are suitable for regular vehicles.

Apart from that, I think it is hard to objectively differentiate between 4wd_only and other roads. The situation might even change depending on the season and weather.

As such, I think we shouldn't implement this. I will therefore close this issue as wontfix.

If you disagree, feel free to create a new issue at Github: https://github.com/gravitystorm/openstreetmap-carto/

Note: See TracTickets for help on using tickets.